Jump to content


Inferno

Member Since 01 Sep 2004
Offline Last Active May 21 2010 12:13 AM

Topics I've Started

Blue At2k

01 October 2004 - 02:32 AM

Now I know that many people have posted about problems with their AT2Ks, but I didn't find any that fit the profile of my problem. I plugged the over-pressure release valve on both the red and blue AT2Ks that I bought from Target. The red one works great; couldn't be happier with it. The blue one, however, fails to pump correctly. When I pull OUT on the pump there is resistance, and when I push the pump back into the gun, there is absolutely no resistance, opposite of all my other Nerf guns. It's like the pump is sucking air out of the tank. I tried pumping it slowly, and noticed resistance when I pulled out AND pushed back in...that sounded gross.

I opened up both guns, switched the pumps and got the same result. The pump from the red AT2K worked fine on the blue AT2Ks innards, but the blue AT2Ks pump just sucked again on the red AT2Ks innards. Any advice or expertise anyone could share on this subject would be greatly appreciated.

It's Been Too Damn Long

02 September 2004 - 02:52 AM

Wow, it has been a long time since i was in a nerf forum. I don't know if anyone from nerfonline remembers me, but I used to be Psycho1 there. I also had a friend that went there all the time; Nerf Psycho. Ya'll might remember him better. Last time I was on a nerf forum was probably 4 or 5 years ago. I stopped nerfing in about 7th or 8th grade, just because my nerf buddies weren't really up to it anymore. But I've kept all my guns, and now my nephew is in his prime for nerf wars (he kinda resparked my interest).

I just thought I'd see if I could get my self back into it. So here I am. Damn, it feels good to be back. If anyone in Texas wants to nerf, let me know. Thanks.