Jump to content


X RUSHED X

Member Since 05 Feb 2009
Offline Last Active Feb 01 2010 06:21 PM

Posts I've Made

In Topic: Modded Recon Stops Shooting Need Help

21 September 2009 - 04:05 PM

It could be possible that it's the electrical tape. After a while, at least in my experience, it starts to leave a shitty residue in your plunger tube, and it can really screw with your gun's performance.

In Topic: Longshot Help

28 August 2009 - 06:32 PM

The breech hole, like the one a coupe inches away from the plunger tube?

I have not covered that yet?


I meant that I have.

In Topic: Longshot Help

28 August 2009 - 11:59 AM

Make sure of two things.

1: You have the dart tooth in the gun.
2: You have covered the hole in the stock breech with etape or something.

That's all I can say.


I've both of those components in my gun. I covered the breech hole with hot glue and it's held out so far. Are there any other reasons that it would be performing below par?

In Topic: Longshot Help

27 August 2009 - 11:58 PM

I'm also having Longshot troubles. I did all the modifications he mentioned, but I only used two Maverick springs. I'm hitting about 35 ft. Should I be getting better ranges? And if not, could some one sell me a BBB spring. PM me please.

In Topic: Need Help Fixing Maverick

13 August 2009 - 10:40 PM

I had the same problem a few months back. When I asked Angel about it, his response was, "Make room for a machine screw. Then simply washer each side and put a acorn nut on the one threaded end."

If that doesn't work, scrap it. Mavericks are only around $7.