Jump to content


Photo

Swarmfire problem

yeah, so I fucked up again.

2 replies to this topic

#1 IamSparticus

IamSparticus

    Member

  • Members
  • 24 posts

Posted 25 August 2011 - 12:01 PM

Alright, so I was doing this mod to my Swarmfire, and after I had removed the ARs and was epoxying the plunger back together, I ran into some difficulties. on the epoxy I used, it directed me to clamp the bond. Now, I'm not sure if that was for the 5-minute setting period, or the 24-hours-till-full-strength, but when I removed the clamp, the foam turret seal was compressed and deformed from the force of the clamp.

My question is, how can I fix this, and if not, what are some suggestions for replacing the seal? should I even be worried?

thanks.

IAmSparticus
  • 0
The end of the world is upon us...
I ran out of duct tape yesterday.

#2 soloz1

soloz1

    Member

  • Members
  • 87 posts
  • Location:Honolulu, Hawaii
  • State:Hawaii
  • Country:United States

Posted 25 August 2011 - 01:48 PM

Add craft foam, lube, be happy!
  • 0

...Man, if I lived on Oahu, I would've dropped in on Pineapple by now. On Molokai. Via Kayak. ...Fuck, we're depending on you guys to defend us from 3DBBQ, get your shit together already.


#3 ice

ice

    Member

  • Members
  • 895 posts

Posted 25 August 2011 - 08:32 PM

I've removed the craft foam on one of my turrets and replaced it with a 1-1/2 rubber wash, aligned the original hole in the washer over one of the plunger tubes openings, and then dremeled out a second one underneath to complete it. Actually increases the seal to slightly better then stock, and allows for re-loading turrets. Then, simply trim away at the outside of the washer till it's the same dimensions as the stock foam one. Enjoy :)
  • 0
<!--quoteo(post=206428:date=Jan 25 2009, 05:17 PM:name=Mukersman)--><div class='quotetop'>QUOTE(Mukersman @ Jan 25 2009, 05:17 PM) View Post</div><div class='quotemain'><!--quotec-->
Turd stefans. When I pulled these out of the pillow case i was just like, what... the... fuck...
Muker
<!--QuoteEnd--></div><!--QuoteEEnd-->


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users