Jump to content


Photo

Some Maverick Mod Troubles

I tried to do the barrel rotation improvement...

4 replies to this topic

#1 Yazzeh

Yazzeh

    Member

  • Members
  • 132 posts
  • Location:Montreal, Quebec, Canada, H4A 1R2

Posted 18 May 2007 - 08:04 AM

I followed the beginning of CaptainSlug's Maverick Drop Clip to improve the barrel rotation's effeciency and such, but now I've run into a spot of trouble. I epoxied the two pieces together all fine and dandy, screwed everything tightly back into place and closed the casing with the screws that I've been so frantically screwing and unscrewing over the past two days that the heads are starting to wear away despite my care.

The problem is that the barrel wont even rotate. I pull the trigger, and it barely even twitches. Funny thing is, when I unscrew the casing, the barrel rotates fine with the trigger, but when I screw the casing back on... It just jams. I can't figure out exactly what the problem is, but I figured out that pressing the two bumps on the side of the casings together when it's closed (right before where the barrel is housed) I can use the trigger to rotate the barrel pretty normally. But when I let go, it just jams. Any ideas?
  • 0

#2 CaptainSlug

CaptainSlug

    Resident Mad Scientist

  • Administrators
  • 4,761 posts

Posted 18 May 2007 - 08:59 AM

You didn't put the gun back together correctly is all I can figure. The rotation mechanism has to be seated properly.

Edited by CaptainSlug, 18 May 2007 - 09:02 AM.

  • 0
The little critters of nature, they don't know that they're ugly. That's very funny, a fly marrying a bumble bee. I told you I'd shoot, but you didn't believe me. Why didn't you believe me?

#3 Yazzeh

Yazzeh

    Member

  • Members
  • 132 posts
  • Location:Montreal, Quebec, Canada, H4A 1R2

Posted 18 May 2007 - 05:48 PM

I'm quite certain it's all in it's proper place and securely fastened. This is really bugging me...

Here's a quick photo:

Posted Image
  • 0

#4 Famine

Famine

    Member

  • Members
  • 545 posts

Posted 22 May 2007 - 09:58 PM

::Removing my own advice::

Edited by Famine, 22 May 2007 - 10:05 PM.

  • 0
~Famine
of Mag-7
East Coast Nerf 2005: Step It Up.
East Coast Nerf 2006: That's more like it.
East Coast Nerf 2007: I'm not driving to Massachusetts again.
East Coast Nerf 2008: Day of Regret.
East Coast Nerf 2009: Quid pro quo, douchebags!

#5 Yazzeh

Yazzeh

    Member

  • Members
  • 132 posts
  • Location:Montreal, Quebec, Canada, H4A 1R2

Posted 23 May 2007 - 07:41 AM

You didn't put the gun back together correctly is all I can figure. The rotation mechanism has to be seated properly.



Haha, actually, I fixed my problem a couple days ago. The problem wasn't that the mechanism wasn't seated properly. The screws holding the back piece of the mechanism in place weren't as tight as possible. Woops!

Haha, thanks anyways.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users