Jump to content


Photo

Agh, Blastfire Problem


6 replies to this topic

#1 chris

chris

    Member

  • Members
  • 87 posts

Posted 24 November 2005 - 07:32 PM

After attempting cxwq's Blastfire mod I noticed there was a problem: The slide wouldn't cock, it'd slide back down. Here's me doing his mod so far:

Posted Image

Compared to

Posted Image


That's cxwq's, and after staring at that, I realized I was missing some kind of spring. Here's a close-up of my problem

Posted Image

The closest I've gotten to searching for this problem is here. But the pictures don't work!

Can someone point me out to where to get a replacement spring for this or tell me what it looks like (I have many spare parts lying around from where it might've flew out). Your help is greatly appreciated.
  • 0

#2 DTReaper

DTReaper

    Member

  • Members
  • 309 posts
  • Location:Stratford, Connecticut

Posted 24 November 2005 - 07:53 PM

It looks like you are missing a piece just above the trigger. You probably need that.

-DTR
  • 0
QUOTE(VACC @ Dec 5 2008, 12:09 AM) View Post

That's it. I'm done. I'm sorry there are breasts on the Internet.

#3 chris

chris

    Member

  • Members
  • 87 posts

Posted 24 November 2005 - 08:20 PM

Ah sorry. I didn't have that piece in it at the time (nor the trigger spring). I'm talking about the spring in the cocking handle (I think) that I'm missing. Thanks anyways DTReaper.
  • 0

#4 euphemism

euphemism

    Member

  • Members
  • 262 posts
  • Location:75 Edge Hill Road, Milton, MA

Posted 24 November 2005 - 08:34 PM

There are two editions of the blastfire, one has a cocking handle return spring and one deosn't, you must have the old edition.
  • 0

#5 chris

chris

    Member

  • Members
  • 87 posts

Posted 25 November 2005 - 12:05 AM

There are two editions of the blastfire, one has a cocking handle return spring and one deosn't, you must have the old edition.

So there's not really any problem with my Blastfire at all? I guess I must have put it back sloppy. Anyways, the year of my Blastfire is 2001, I don't know if that's the old or new edition. Thanks.
  • 0

#6 paul1

paul1

    Member

  • Members
  • 5 posts

Posted 25 November 2005 - 02:18 PM

Speaking of problems, I have a Rapidfire 20 that the pupming mechanisim is broken in it. The best I can do is take the darts and throw them by hand.

Its the onle Nerf gun I have. :huh:
  • 0

#7 The Infinite Shindig

The Infinite Shindig

    Arma-what-now?

  • Contributors
  • 1,383 posts

Posted 25 November 2005 - 05:04 PM

Speaking of problems, I have a Rapidfire 20 that the pupming mechanisim is broken in it. The best I can do is take the darts and throw them by hand.

Its the onle Nerf gun I have. :huh:

We have a few problems here:

1. Try searching your problem first. The forum search button is extremely powerful.
2. The problem with your RF20 shouldn't come up in an blastfire thread.
3. The thread was better than this, but you should have realized to not double post your problem. We will help you, but don't be annoying about it.
  • 0
Shindig of the Lawn Chair Mafia

<a href="http://www.albinobla.../flash/posting" target="_blank">Posting and You</a>


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users