Jump to content


Photo

Alpha Trooper - failed modification


3 replies to this topic

#1 seuw48

seuw48

    Member

  • FNG2
  • 2 posts
  • Country:Netherlands

Posted 14 January 2019 - 08:01 AM

Hello all!
I've tried to modified my Alpha Trooper and something went wrong.  Was following one of the YouTube videos on modification of this one.

 

Blaster no longer cocks. The spring is pushed with pump grip but nothing prevents it from moving back.

 

I've tried to do the following mod (based on worker package):

- drilled air-restrictor

- removed magazine lock, trigger and slam-fire locks

- changed O-ring on breach

- added rubber ring inside the plunger

- change spring to more powerful one

- change spring on catch mechanism

 

It is my first modification, so I kind of unsure what is wrong. First I thought that catching mechanism is too weak for spring - so tried to put stronger one and to switch back to stock spring - but it's still the same. (It was same result with trigger lock installed.)

 

Any ideas or suggestions? 

 

 

I've attached the image how it looks like now.

Attached Thumbnails

  • alpha_trooper.jpg

  • 0

#2 An unnamed cell

An unnamed cell

    Member

  • Members
  • 39 posts
  • Country:United States

Posted 15 January 2019 - 10:08 PM

I would check out the plunger padding.

 

I'm not quite sure what specifically is happening when you try to prime the blaster, but I'd be willing to take a guess. Unless the internals stay in place when you prime (in which case you would want to check the metal rod's connection to the boltsled), then you probably padded the plunger too much.

 

Either that or the tougher spring warped your priming rod (metal bar from the front), but it's hard to tell.

 

Best of luck with this, we've all been there at some point. Hope this helps.


  • 0

The plebiest of the plebs.


#3 Larry D

Larry D

    Member

  • FNG1 
  • 1 posts
  • Location:Frisco,Texas,75033
  • State:Texas
  • Country:United States

Posted 21 January 2019 - 03:08 PM

Plunger tube is upside down - tooth part is on the lower side.
Locks you need to put two of the locks back in (1)the one that is around the clip lock - cut out the bottom part like you would on a retaliator.
(2) the one that locks the bolt sled in the looks like a fork.
  • 0

#4 seuw48

seuw48

    Member

  • FNG2
  • 2 posts
  • Country:Netherlands

Posted 23 January 2019 - 04:59 AM

@An unnamed cell - thank man, metal rod looks fine, regarding padding - looks OK too - however not sure.

 

@Larry D- thanks. Will try it when I'm back home.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users