Jump to content


Need Apollo Help!

No replies to this topic

#1 ILikeShotguns



  • Members
  • 11 posts

Posted 21 January 2017 - 03:21 PM

So I finally decided to mod my Apollo. Popped it open, took out the AR, took out the locks, put it back together, and it worked fine, for like 10 mins. The charging handle would slide freely, and engage the chamber, but not prime. Opened it up again. The weak middle  gear got stripped some, so I fixed that. closed up the gearbox and tried to prime, didn't work. Realigned the gears and that weird sliding ratchet teeth thing, and it did prime - kinda. It'll prime back, but once the charging handle is about 80% back, it'll fire, regardless of the catch or trigger or anything. Once it does this, the sliding gears are out of alignment and then it's basically inoperable again until I realign it.

I have no idea what to do.

EDIT: after manually pushing the plunger back, it caught, and fired, meaning the problem is in the gearbox (I'm thinking that the gears slipped and let the plunger drop when it was mostly primed). Looked at the gears again and the middle gear (between the large main gear and the flanged gear) is totally fried and unusable. Does anyone make replacements of these? Otherwise I need a donor Apollo or this gun is done forever.

Edited by ILikeShotguns, 22 January 2017 - 12:39 AM.

  • 0

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users