Jump to content


Photo

EAT help

I need help

2 replies to this topic

#1 Zack Dorris

Zack Dorris

    Member

  • Members
  • 74 posts
  • Location:62812
  • State:Illinois
  • Country:United States

Posted 04 July 2014 - 09:37 AM

Hello fellow nerfers I recently received an EAT in a trade and I removed the locks and ARs. I have one slight problem though. I think I took out a lock that shouldn't have been taken out. Here is a picture of my internals now.
Posted Image
Please tell me if I took out a lock that shouldn't have been because my mag falls out when I prime back the blaster. Thanks in advance.
  • 0

#2 Naturalman7

Naturalman7

    Member

  • Contributors
  • 158 posts
  • Location:Boise, Idaho
  • State:Idaho
  • Country:United States

Posted 04 July 2014 - 10:12 AM

The only thing that keeps the clip in is that orange piece in the magwell. Make sure that when you insert a clip, push it all the way in. I've found that some clip blasters can't hold in heavier clips. Try putting a stronger spring in that orange piece and see if that helps.

Actually, it looks like your clip piece is missing its spring entirely, there's your problem. It'll hold a clip if you keep the clip release pushed forward, but if the piece slides back, the clip will be released and fall out. The bolt catches on the lip of the clip to keep it in, but once it primes the bolt slides back and the clip falls.

Edited by Naturalman7, 04 July 2014 - 10:15 AM.

  • 0

#3 Zack Dorris

Zack Dorris

    Member

  • Members
  • 74 posts
  • Location:62812
  • State:Illinois
  • Country:United States

Posted 04 July 2014 - 10:23 AM

Thanks! The internals like exploded out when I opened it. I'll try that and see if it fixes it.
FIXED THANKS

Edited by Zack Dorris, 04 July 2014 - 10:42 AM.

  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users