Jump to content


Photo

Rampage clip well coming loose


5 replies to this topic

#1 Jeo

Jeo

    Red Team: HooRah!

  • Members
  • 93 posts
  • Location:Canberra
  • State:Australian Capital Territory
  • Country:Australia

Posted 29 July 2012 - 03:01 AM

Has anyone else had this happen to them? The clip well on both my Rampages come loose with very little effort.

I first noticed this during an indoor game where I clipped a wall with my drum as I ran past, but I can replicate it easily and consistently by hitting it from the back of the clip.

What it should look like.
Posted Image

What happens.
Posted Image
  • 0

#2 Defender 7

Defender 7

    Member

  • Members
  • 128 posts
  • State:Nevada
  • Country:United States

Posted 29 July 2012 - 04:16 AM

No this never happened to me on a raider or a rampage, but did you put it in the wrong way?

Edited by Defender_7, 29 July 2012 - 04:17 AM.

  • 0
I like bacon.

#3 evilbunnyo

evilbunnyo

    Member

  • Members
  • 404 posts
  • Location:Stony Point, New York, !0980
  • State:New York
  • Country:United States

Posted 29 July 2012 - 04:20 AM

Well Im not sure what the problem is but if you want to always keep it on you can use a glue for plastics. Not superglue though that degrades it.
  • 0
Silence is golden but duct tape is silver

#4 Jeo

Jeo

    Red Team: HooRah!

  • Members
  • 93 posts
  • Location:Canberra
  • State:Australian Capital Territory
  • Country:Australia

Posted 29 July 2012 - 06:51 AM

I've owned close to a dozen Raiders and none have ever come loose, even when specifically trying to. To get the photos today I honestly would have only knocked it with say equivalent force of priming a stock maverick.

I've glued one of them today with a general adhesive. Will see how it goes tomorrow night.
  • 0

#5 Pause

Pause

    Member

  • Members
  • 107 posts
  • Location:Honolulu, Hawaii
  • State:Hawaii
  • Country:United States

Posted 29 July 2012 - 05:59 PM

My friend had this problem with a Raider. He just returned it. I think Ice had this problem with a Raider, so he just glued it on.
  • 0
-Pause-

http://nerfpause.blogspot.com/

Heh.

USER WAS BLAND IN THIS POST


#6 Jeo

Jeo

    Red Team: HooRah!

  • Members
  • 93 posts
  • Location:Canberra
  • State:Australian Capital Territory
  • Country:Australia

Posted 08 November 2012 - 10:03 PM

Update!

I glued one shut, it's been fine ever since.
Have seen multiple other blasters with the same problem, they seem to come loose really easily.

I'd say this might be an Austrlian thing but most of the Rampages I've seen here are US spec from Amazon anyway. Anyone else running into this issue?
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users