Jump to content


Photo

Splitfire Problem

Looking for advice

11 replies to this topic

#1 Keith

Keith

    Member

  • Members
  • 181 posts
  • Location:Wichita, Kansas 67204

Posted 06 November 2010 - 08:03 PM

I got an old Splitfire today, but it isn't working properly. Here's what's happening:

When I pump there's a lot of resistance, I can hear air escape around the pump handle and it pushes itself partially back out of the pump tube.

Sometimes if I pump a few times then take the pump handle out air still slowly escapes from the pump tube.

If I pump then pull the little trigger pieces a very small amount of air escapes around them.

If i push in the valves in the front (barrel side) of the tanks after pumping, a tiny bit of air escapes, then if I pump again they shut.

Note that I already cut the stock barrels down so I could see the valves better and I cleaned and re-lubricated the pump. As far as I can see there isn't any debris in any of the valves.

Can anyone tell me what's wrong and how to fix this? I'd love to get this cool old blaster working so I can shoot it at my friends!
  • 0

#2 Blue

Blue

    Member

  • Members
  • 2,222 posts

Posted 06 November 2010 - 08:16 PM

I have had a few hornet blast valves do what your sf trigger is doing, I don't know what it means other than not functioning. You might get lucky by soaking it in silicone grease or silicone spray. As far as the pump, those are typical results of a shot check valve, there are two in the sf pump end. I doubt you are going to get this thing working, but lots of silicone might help.
  • 0

#3 Keith

Keith

    Member

  • Members
  • 181 posts
  • Location:Wichita, Kansas 67204

Posted 06 November 2010 - 08:52 PM

Thanks for the reply, Blue. I'm soaking it with lube now. Anyone else have an idea?
If I don't have luck with anything else I'll take it completely apart to see if I can find the problem or at least just see what the guts look like. Is boiling water the way to go there?
  • 0

#4 jaybo1996

jaybo1996

    Member

  • Members
  • 110 posts
  • Location:Peabody, Massachusetts

Posted 06 November 2010 - 10:02 PM

Sounds like a busted check valve. I would replace the pump.
  • 0
01:15 N9> The problem with nerfers: We're around plastic. Plastic contains estrogenic compounds, so we're more feminine than the rest of the world.

WTF, are you in Tony Stark's basement!?'


#5 Mehku

Mehku

    Member

  • Members
  • 383 posts
  • Location:Milwaukee
  • State:Wisconsin
  • Country:United States

Posted 07 November 2010 - 12:10 AM

Taking apart your splitfire is just a sure way to piss yourself off - You'll never get the fucker to work properly, if at all after taking it apart even if it was a good model. If you can't fix your problem with lube, your splitfire is fucked.
  • 0

#6 Banshee

Banshee

    Member

  • Members
  • 668 posts
  • Location:Chandler, Arizona

Posted 07 November 2010 - 12:04 PM

Taking apart your splitfire is just a sure way to piss yourself off


Well I don't know what that means, the Split Fire is one of the easiest guns to open and work on. But as said before, it sounds like a shot check valve. If you have another pump from another gun, you could try plugging it into the hose for the tanks. if not, you could drill out the check valve and order a new valve that goes between the hoses.
  • 0
Like my page on Facebook! PM me, I do commissions!

#7 Keith

Keith

    Member

  • Members
  • 181 posts
  • Location:Wichita, Kansas 67204

Posted 07 November 2010 - 12:32 PM

Taking apart your splitfire is just a sure way to piss yourself off - You'll never get the fucker to work properly, if at all after taking it apart even if it was a good model. If you can't fix your problem with lube, your splitfire is fucked.


That's the thing though, it's already not working at all, it can't be any more fucked if I try :P



Well I don't know what that means, the Split Fire is one of the easiest guns to open and work on. But as said before, it sounds like a shot check valve. If you have another pump from another gun, you could try plugging it into the hose for the tanks. if not, you could drill out the check valve and order a new valve that goes between the hoses.



I might try replacing the pump somehow, but there is no hose, it's a solid plastic manifold type of thing that's all glued together.

Anyway, thanks for the replies, guys.
  • 0

#8 Banshee

Banshee

    Member

  • Members
  • 668 posts
  • Location:Chandler, Arizona

Posted 07 November 2010 - 08:19 PM

I might try replacing the pump somehow, but there is no hose, it's a solid plastic manifold type of thing that's all glued together.

Anyway, thanks for the replies, guys.


That's right, I remember now, I sold mine a while ago, I'm not sure, but that means you''l need to put hosing in. Try putting in some connectors or something that you attach hosing too.
  • 0
Like my page on Facebook! PM me, I do commissions!

#9 Blue

Blue

    Member

  • Members
  • 2,222 posts

Posted 07 November 2010 - 09:07 PM

If you try to replace the pump, you will need two pumps. There are two check valves in the end of the pump, if they are messed up you can try attaching two separate good pumps to them.
  • 0

#10 imaseoulman

imaseoulman

    Member

  • Members
  • 1,005 posts
  • Location:DFW
  • State:Texas
  • Country:United States

Posted 08 November 2010 - 10:24 AM

No, you don't need two pumps. Just another check valve. Also, Banshee, these are a pain to work on. You don't have much space to add the tubing behind the poppet and adding it anywhere else is asking for trouble. I've fixed five or six of these over the years and they've always taken more work than any other blaster. It probably is a check valve, but it's hard to tell without actually handling it. Before you make any cuts in it, make sure you understand COMPLETELY how it works, or you'll probably end up screwing it up. Good luck.
  • 0

#11 Blue

Blue

    Member

  • Members
  • 2,222 posts

Posted 08 November 2010 - 12:01 PM

No, you don't need two pumps. Just another check valve. Also, Banshee, these are a pain to work on. You don't have much space to add the tubing behind the poppet and adding it anywhere else is asking for trouble. I've fixed five or six of these over the years and they've always taken more work than any other blaster. It probably is a check valve, but it's hard to tell without actually handling it. Before you make any cuts in it, make sure you understand COMPLETELY how it works, or you'll probably end up screwing it up. Good luck.


If you have a single check valve before the two broken check valves, what keeps the air tanks seperate from each other?
  • 0

#12 imaseoulman

imaseoulman

    Member

  • Members
  • 1,005 posts
  • Location:DFW
  • State:Texas
  • Country:United States

Posted 08 November 2010 - 12:49 PM

I wasn't saying you only need a total of one check valve. Most pumps include a check valve, by adding another check valve you have two. Because SF's always fire sequentially you don't have to worry about firing the second chamber first, so adding a(nother) check valve after the branch to the second tank, you're covered. However, I'll reiterate that adding tubing to a SF is not easy.

And as for your other point, depending on the setup, the second tank would just fire with the first tank. If there is a flow path from the pilot exhaust of tank #2 to anywhere in the tank #1 system (which you seem to be assuming) it will most likely just double fire. I've done several setups like this for volleys and the like and it takes very little flow. The firing of tank #1 is VERY unlikely to be affected at all. SF's have very small tanks/poppets and exhaust very quickly, but even ignoring that, it shouldn't be affected. Again, this does depend on setup.

Edited by imaseoulman, 08 November 2010 - 12:50 PM.

  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users