Jump to content


Photo

Firefly Modding Problem

god i hate fireflies

11 replies to this topic

#1 sidamazo

sidamazo

    Member

  • Members
  • 68 posts
  • Location:kearny nj

Posted 28 April 2010 - 07:41 PM

I was modding my new firefly for a couple weeks now since I only have time on Sundays. Everything works properly except for the plunger tube...I'm not sure what exactly is happening, but there's almost no air coming out of it. It has the same spring, and the only thing I modded was taking out the AR's. And i took out all of the garbage like the light, and the battery case.

Problem: Plunger tube isn't letting out air even though i barely touched it.

It worked perfectly fine before i opened it up.
  • 0

#2 cheesypiza001

cheesypiza001

    Member

  • Members
  • 752 posts
  • Location:Connecticut

Posted 28 April 2010 - 07:47 PM

The plunger head may just need to be lubricated (with a silicone based lubricant).
  • 0

#3 Blue

Blue

    Member

  • Members
  • 2,222 posts

Posted 28 April 2010 - 08:56 PM

Your turret sealing piece might be gone, does the plunger rod make a crash sound when you fire or does it move slow?
  • 0

#4 moosa

moosa

    Member

  • Members
  • 243 posts
  • Location:Bangor, ME

Posted 29 April 2010 - 12:51 AM

I suspect Blue is right. However, with the ARs now removed, the plunger shouldn't move slow anyways.

If you have any Fireflies you don't want any more I'll take them. :D
  • 0
Yes.

#5 sidamazo

sidamazo

    Member

  • Members
  • 68 posts
  • Location:kearny nj

Posted 30 April 2010 - 05:50 PM

It makes a really loud crash when i fire.
  • 0

#6 Mr BadWrench

Mr BadWrench

    Member

  • Members
  • 781 posts
  • Location:Bum Funk Ohio

Posted 30 April 2010 - 06:01 PM

Fireflys hate you too...

some pics would be nice if you're expecting help
  • 0
NerfChat IRC Chatroom Click to chat!

#7 wingd man

wingd man

    Member

  • Members
  • 514 posts
  • Location:Austin,TX 78751

Posted 30 April 2010 - 06:06 PM

In that case the problem is definitely a terrable seal. Blow on the end of the plunger tube to test for leaks. Make sure your o-rings are in place, all that jazz... If you really can't fix it, people will definitely buy it for more than it's worth.
  • 0

#8 dmactheballer

dmactheballer

    Member

  • Members
  • 6 posts

Posted 30 April 2010 - 09:28 PM

I was modding my new firefly for a couple weeks now since I only have time on Sundays. Everything works properly except for the plunger tube...I'm not sure what exactly is happening, but there's almost no air coming out of it. It has the same spring, and the only thing I modded was taking out the AR's. And i took out all of the garbage like the light, and the battery case.

Problem: Plunger tube isn't letting out air even though i barely touched it.

It worked perfectly fine before i opened it up.


This is exactly what I did and got the same result. It only shoots 10' now as opposed to the remarkable....hold your breath.... 15' before modding. If i sealing it doesn't work (which is difficult with a rotating barrel) I'll probably just chunk the stupid thing.
  • 0

#9 dmactheballer

dmactheballer

    Member

  • Members
  • 6 posts

Posted 30 April 2010 - 09:30 PM

\

If you have any Fireflies you don't want any more I'll take them. ;)



I'll sell you mine with nothing done to it except AR removal

Edited by dmactheballer, 30 April 2010 - 09:33 PM.

  • 0

#10 moosa

moosa

    Member

  • Members
  • 243 posts
  • Location:Bangor, ME

Posted 01 May 2010 - 12:48 AM

\


If you have any Fireflies you don't want any more I'll take them. ;)



I'll sell you mine with nothing done to it except AR removal


Well buddy, it was a joke, and I wasn't looking to pay anything for it. Also this isn't really the place for this.
  • 0
Yes.

#11 sidamazo

sidamazo

    Member

  • Members
  • 68 posts
  • Location:kearny nj

Posted 02 May 2010 - 11:09 AM

Thanks for the suggestions. I'll try to look for leaks and properly place the O-rings. There's almost no space between the end of the plunger tube and the back of the turret when firing though, so i don't think that's the problem.
  • 0

#12 Tigg

Tigg

    Member

  • Members
  • 6 posts

Posted 05 May 2010 - 12:58 AM

I was modding my new firefly for a couple weeks now since I only have time on Sundays. Everything works properly except for the plunger tube...I'm not sure what exactly is happening, but there's almost no air coming out of it. It has the same spring, and the only thing I modded was taking out the AR's. And i took out all of the garbage like the light, and the battery case.

Problem: Plunger tube isn't letting out air even though i barely touched it.

It worked perfectly fine before i opened it up.


I was modding a firefly a while back and I had a similar problem. They seem to be incredibly touchy with the lineup of the plunger tube and the hole in the back of the cylinder where the dart is. On mine, when it lines up correctly, it shoots great. When it doesn't, it acts like there is no air. Perhaps you have the same issue with your gun, and it only appears to be a plunger problem. Or maybe I have misunderstood entirely, but I do hope this helps.
  • 0
TIGG


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users