Jump to content


Photo

Magstrike Reassembly

I need a litte help.

4 replies to this topic

#1 Roschili

Roschili

    Member

  • Members
  • 133 posts
  • Location:TN 37763

Posted 26 January 2010 - 06:24 PM

Today I took my Magstrike apart to try to fix an air leak that it had. I think I fixed the leak but now I cannot get the gun back together because I cannot get the bladder in place. I do not want to force the bladder in because I do not want to break it. Below are some pictures of what I am trying to do. Can anyone tell me what I am doing wrong or if I am just supposed to force the white piece shown in the second picture down over the end of the bladder? Also, is the bladder just put on too far? Thanks.

Posted Image

Posted Image

I have one more question, what does everyone else use to fix air leaks?
Thanks again.
  • 0
QUOTE
I think my bullshit meter just exploded. What the fuck you talkin' 'bout, Willis?

#2 Retiate

Retiate

    Member

  • Members
  • 778 posts
  • Location:Gig Harbor, Washington
  • State:Washington
  • Country:United States

Posted 26 January 2010 - 06:31 PM

The bladder is pain to get screwed back down to the case. Have a person push the white piece to the screw wells while you screw it down. Everything looks like it's in the right place, it just requires some force to get back together.
And I used Plumbers Goop on my leaky Magstrike.
  • 0

#3 Roschili

Roschili

    Member

  • Members
  • 133 posts
  • Location:TN 37763

Posted 26 January 2010 - 10:17 PM

The bladder is pain to get screwed back down to the case. Have a person push the white piece to the screw wells while you screw it down. Everything looks like it's in the right place, it just requires some force to get back together.
And I used Plumbers Goop on my leaky Magstrike.

Awesome thank you very much!
  • 0
QUOTE
I think my bullshit meter just exploded. What the fuck you talkin' 'bout, Willis?

#4 Roschili

Roschili

    Member

  • Members
  • 133 posts
  • Location:TN 37763

Posted 31 January 2010 - 05:09 PM

Sorry for the double post, but I got it back together the way Retiate said, thanks again. Now I am having trouble with it leaking very badly. The bladder is not expanding at all. None of the air is making it that far, but I cannot find a leak in the hose or anything. I hear the air coming out but see no problems, obviously there is one though. I took it apart and tried putting it back together and that did not help, I made sure the black bladder was all the way on but that did not make a difference. Any suggestions?
  • 0
QUOTE
I think my bullshit meter just exploded. What the fuck you talkin' 'bout, Willis?

#5 Vincent

Vincent

    Member

  • Members
  • 138 posts
  • Location:Chandler, AZ, US of A

Posted 31 January 2010 - 05:23 PM

Submerge the internals in water and look for a trail of air bubbles coming out while you pump. There is your leak. Make sure to dry everything well, though.
  • 0
QUOTE(Carbon @ Jul 14 2009, 07:50 PM) View Post

Heresy. Nothing beats pink flamingos.



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users