Jump to content


Photo

Fury Fire Not Rotating


9 replies to this topic

#1 WratH

WratH

    Member

  • Members
  • 388 posts
  • Location:Manitoba, Canada

Posted 21 December 2009 - 10:29 PM

So I took my Fury Fire apart to mod. I got the AR's out and put the turret back together. I do have more plans for it but not unless I can fix it. I can't get it to rotate. I get all the pieces in, as per internal pictures. I pull the trigger without the shell on and it rotates fine. Put the shell on and nothing happens when I pull the trigger (besides the gun fires). What am I doing wrong?
  • 0
Death be not proud. Though some have called the mighty and dreadful... Thou art not so.

#2 Banshee

Banshee

    Member

  • Members
  • 668 posts
  • Location:Chandler, Arizona

Posted 21 December 2009 - 10:41 PM

Does it rotate manually? Does it rub against anything? Does the piston move or is it just the turret that doesn't move?
  • 0
Like my page on Facebook! PM me, I do commissions!

#3 WratH

WratH

    Member

  • Members
  • 388 posts
  • Location:Manitoba, Canada

Posted 21 December 2009 - 10:47 PM

Everything is completely fine, the only problem is it doesn't rotate when the top shell is on.
  • 0
Death be not proud. Though some have called the mighty and dreadful... Thou art not so.

#4 Banshee

Banshee

    Member

  • Members
  • 668 posts
  • Location:Chandler, Arizona

Posted 21 December 2009 - 11:03 PM

But with it off it rotates and fires normally. That's strange. I could help more if i actually owned one, I have a few RF20's and to my understanding they're the same gun in different plastics, but I can't think of anything that's going wrong. Perhaps just take everything out and put it back in, sometimes that helps.

Or possibly you're having the problem that happens to a good percentage of RF20's. Sometimes out of the box, they don't rotate. The slide doesn't return far enough back to catch another notch in the turret and doesn't rotate. If thats the case then there is nothing to my knowledge that can fix it.
  • 0
Like my page on Facebook! PM me, I do commissions!

#5 WratH

WratH

    Member

  • Members
  • 388 posts
  • Location:Manitoba, Canada

Posted 21 December 2009 - 11:04 PM

This gun... is nothing like the RF20. Sorry dude.
  • 0
Death be not proud. Though some have called the mighty and dreadful... Thou art not so.

#6 Banshee

Banshee

    Member

  • Members
  • 668 posts
  • Location:Chandler, Arizona

Posted 21 December 2009 - 11:11 PM

Oh snap... I'm thinking of the wild fire.... haha.
  • 0
Like my page on Facebook! PM me, I do commissions!

#7 flipoffacliff

flipoffacliff

    Member

  • Members
  • 110 posts
  • Location:Bay Area,CA

Posted 21 December 2009 - 11:12 PM

Try loosten the screws around the turret. That helped me fix my maverick. If that doesn't work maybe try cleaning the rotating mech. There might be some foreign material around there. My last tip maybe it needs to be lubricated with (choice of lubricant).
  • 0

#8 WratH

WratH

    Member

  • Members
  • 388 posts
  • Location:Manitoba, Canada

Posted 21 December 2009 - 11:48 PM

I have had the whole turret apart, it doesn't need lube or anything, everything is functioning fine, it just won't turn. The black rod moves back and forth along its track, and it pulls the orange part of the rotating mech back instead of turning the turret. I've tried all screws in the shell, no screws, everything. It just won't rotate, tis why I'm stumped.
  • 0
Death be not proud. Though some have called the mighty and dreadful... Thou art not so.

#9 flamingeyes245

flamingeyes245

    Member

  • Members
  • 112 posts

Posted 22 December 2009 - 11:14 AM

Could you post some pics?
That would really help.

I think it may be that either something is catching, or there is a loose screw.
  • 0
Keep your friends close,
And your Nerf guns closer.

External Modification contest, check it out!


QUOTE
Using anything I write as a sig makes your penis shoot rainbows. Bitches LOVE rainbows
^^VACC

#10 wingd man

wingd man

    Member

  • Members
  • 514 posts
  • Location:Austin,TX 78751

Posted 22 December 2009 - 01:01 PM

What if you manually push and pull the trigger, while the shell is screwed in?
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users