Jump to content


Photo

Maverick Turret Malfunction

How I fixed it

No replies to this topic

#1 Lt Stefan

Lt Stefan

    Member

  • Members
  • 892 posts
  • Location:Hunterdon County, NJ
  • State:New Jersey
  • Country:United States

Posted 26 August 2009 - 05:08 PM

This is NOT a current issue, I am just posting this so people in the future will be able to do so as well, hopefully with less guess-and-check then me.

So my friend treats his guns very poorly. That being said, he recently broke his Mav and asked me to fix it for him. The gun literally pooped out darts. When I originally gave it to him as a present, I had straw modded it and it worked great. The problem seemed to be with the turret.

It rotated fine, and it looked as if it sealed fine. I couldn't see a crack of light between the turret and the plunger tube, and I had already put AR springs in the front to push it back. Also, when I pulled the turret back and fired, the darts sailed very far. So I knew something was up. I just didn't know what.

I replaced the springs at the front, re lubed it, and took it apart and put it back together again. Then when I was looking at the rod that goes down the center, I noticed it was bent. I was desperate, so I replace it with a spare one I had from a failed turret mod. Turns out, it worked! Loiking back, I now realize that the turret - plunger gap was there, but not at the angle I was looking at. The turret must have been angled against the plunger, with one side against it and a gap on the other side, which would explain why I wasn't seeing light.

So there you have it. In case anyone ever has this problem, now they know how to fix it.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users