Jump to content


Photo

Mavrick Full Barrel Removal Problems.


3 replies to this topic

#1 conray4

conray4

    Member

  • Members
  • 8 posts
  • Location:Shrewsbury, Pennsylvania.17361

Posted 07 June 2009 - 04:22 PM

The problem I have been having with my Maverick started after i finished my full barrel removal mod. When i stick the barrel in, it shoots worse than a stock Maverick, and sometimes it doesn't even shot. I also did the AR removal. I left the peg things in. What"s the problem?

EDIT: I also tried the search function. Nothing came up.

Edited by conray4, 07 June 2009 - 04:23 PM.

  • 0

#2 nerfer63

nerfer63

    Member

  • Members
  • 386 posts
  • Location:fair oaks, CA

Posted 07 June 2009 - 04:43 PM

Remove the pegs or cpvc it. Or it could be a seal problem bewteen the turret and plunger tube.
  • 0

#3 Shrub

Shrub

    Member

  • Banned
  • 862 posts
  • Location:Louisville,KY

Posted 07 June 2009 - 04:58 PM

What you are describing makes no sense. Get some pictures.
Favorite Quotes:
Sorry to hear that man, it's like that one famous bumper sticker, "Shit Happens"
QUOTE
it still seems that your balls drop very rapidly

#4 fallinouttadabox

fallinouttadabox

    Member

  • Members
  • 193 posts
  • Location:Olney, MD

Posted 07 June 2009 - 05:34 PM

It sounds like your timing is off, try taking everything apart and putting it back together.
  • 0
fallinouttadabox (intentionally lowercase): sometimes you want to be somewhere between thinking in the box and thinking out of the box. Trust me, I would know.


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users