Jump to content


Photo

K9 Special Help.

So close

8 replies to this topic

#1 Firefox551

Firefox551

    Member

  • Members
  • 167 posts

Posted 22 May 2009 - 05:50 PM

Alrighty, here's the deal. I just finished constructing my first K9 special, and I have a problem. When I try to cock it, I can see the trigger move as if the catch was engaging, but the plunger seems to stop short just before the catch can engage. It's only off by less than half and inch, and I can't seem to figure out what the problem is. If anyone could help me with this dilemma it would be greatly appreciated. I have studied and worked with the internals of the PAS before so I have an adequate understanding of them, and i can get pictures if anyone needs them.
  • 0
"Whats algebra? I like pudding." - My friend Luke

"We have to remember what we all have in common, and why we are here. Our shared love of shooting things, and each other with little foam darts." - Niaja Blue

#2 StealthMan

StealthMan

    Member

  • DO NOT TRADE
  • 285 posts
  • Location:NYC (manhattan)

Posted 22 May 2009 - 05:53 PM

Post pics, But I suggest taking all the internals out and apart and putting them back together.
  • 0
<!--quoteo(post=212906:date=Feb 16 2009, 06:30 PM:name=TantumBull)--><div class='quotetop'>QUOTE(TantumBull @ Feb 16 2009, 06:30 PM) View Post</div><div class='quotemain'><!--quotec-->I'm not ashamed to admit that I have tried to eat my stefans. They just looked so yummy.
<!--QuoteEnd--></div><!--QuoteEEnd-->

NERF<b>STRONG</b> #108

#3 k9turrent

k9turrent

    Member

  • Members
  • 828 posts
  • Location:Brampton, Ontario, Canada

Posted 22 May 2009 - 05:57 PM

the handle for the clip breech is to close to the handle, move it closer to the edge.

EDIT: You should have just Pm'd me

EDIT 2: LIKE THIS
Posted Image

Edited by k9turrent, 22 May 2009 - 06:07 PM.

  • 0
QUOTE View Post

That's about it. And thanks Angela who helped me with these pictures.. It looks huge in her hands.


HOLY CRAP!

FU ALL

#4 BritNerfMogul

BritNerfMogul

    Member

  • Members
  • 559 posts
  • Location:Merseyside, UK
  • State:England
  • Country:United Kingdom

Posted 22 May 2009 - 05:57 PM

I would say springs. What's in it?

I would recommend changing springs,
  • 0

#5 flyingchicken

flyingchicken

    Member

  • Members
  • 414 posts

Posted 22 May 2009 - 06:03 PM

Like BritNerfMogul said, it's most likely the springs. Often, a certain combination of springs cannot compress enough, therefore not catching. Either the spring(s) you're using cannot be compressed that far, or if you twisted two springs with equal diameter into each other.
  • 0
I am so omniscient; if there was to be two omnisciences, I would be both!

#6 Fresh

Fresh

    Member

  • Members
  • 33 posts

Posted 22 May 2009 - 07:03 PM

I had this same problem. Contrary to popular belief, pump action shotguns do not need that many catch springs. If you reinforced the trigger with epoxy, make sure to round the epoxy so that the plunger rod will catch. If it is flat, the rounded end of the plunger rod will not be able to make it over the reinforcement and therefore will not catch.
  • 0

#7 Shrub

Shrub

    Member

  • Banned
  • 862 posts
  • Location:Louisville,KY

Posted 22 May 2009 - 08:17 PM

The brown piece in thew back of the plunger tube may be broken I had the same problem once but got a new piece and the fixed it.
Favorite Quotes:
Sorry to hear that man, it's like that one famous bumper sticker, "Shit Happens"
QUOTE
it still seems that your balls drop very rapidly

#8 Firefox551

Firefox551

    Member

  • Members
  • 167 posts

Posted 23 May 2009 - 02:06 PM

Alright guys. I have not done any reinforcements, I only have the stock spring in, and the breech handle is at least an inch away. I have taken out the internals and put them back in around five times, and I still can't figure out the problem. I will post pictures later today or tomorrow.
  • 0
"Whats algebra? I like pudding." - My friend Luke

"We have to remember what we all have in common, and why we are here. Our shared love of shooting things, and each other with little foam darts." - Niaja Blue

#9 k9turrent

k9turrent

    Member

  • Members
  • 828 posts
  • Location:Brampton, Ontario, Canada

Posted 23 May 2009 - 02:12 PM

the front of the pump handle might be getting stuck on the other end of the breech
  • 0
QUOTE View Post

That's about it. And thanks Angela who helped me with these pictures.. It looks huge in her hands.


HOLY CRAP!

FU ALL


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users