Jump to content


Photo

Is This Just Happening To Me?

Issues with the Longshot.

8 replies to this topic

#1 numa-t49

numa-t49

    Member

  • Members
  • 119 posts
  • Location:Jackson NJ
  • State:New Jersey
  • Country:United States

Posted 11 May 2009 - 02:20 PM

Ok, so my Longshot is Messed up. The piece that is connected to the plunger chamber by 2 screws, ya it is broken. The two pieces where the screws both broke off. I want to know if this is just happening to me and if there is any known way to fix it or just solve the problem in general. Thanks.
  • 0

#2 Icespartan 1114

Icespartan 1114

    Do NOT buy/sell with me

  • DO NOT TRADE
  • 934 posts
  • Location:Philly, PA 19087

Posted 11 May 2009 - 02:48 PM

Not surprising. You will probably have to get a new one, if you do. Pm me.
  • 0
QUOTE(Zaxbys @ Mar 2 2009, 02:08 PM) View Post
I won't be there til about 1-2...

Church... gotta soak up that Jesus!


NERFSTRONG #51

#3 Fresh

Fresh

    Member

  • Members
  • 33 posts

Posted 11 May 2009 - 04:13 PM

Ask around, make a WTB, I'm sure someone has a broken LS that they are willing to sell for parts. You could always try fixing it. Try using epoxy or superglue then reinforce it with epoxy putty. I'm not sure if it will hold but it's worth a shot.
  • 0

#4 anon-dude

anon-dude

    Member

  • Banned
  • 46 posts

Posted 11 May 2009 - 04:41 PM

That happens to me a lot so I use hot glue to fill the inside it hasn't happened to me again yet.
"Its not illegal...just extremely erotic like masturbating on an airplane" - The Hangover...FTW

A.K.A. NarcolepticPenguin on NR

Zmandudesk82: "@Qwear: Nice name. I'm glad to see the NIC being open to people who are... different."

#5 numa-t49

numa-t49

    Member

  • Members
  • 119 posts
  • Location:Jackson NJ
  • State:New Jersey
  • Country:United States

Posted 11 May 2009 - 08:32 PM

That happens to me a lot so I use hot glue to fill the inside it hasn't happened to me again yet.

Dude that is a great idea. I have to try that. Any way to fix a broken one.
  • 0

#6 nerfnukerz

nerfnukerz

    Member

  • Members
  • 23 posts

Posted 12 May 2009 - 05:48 AM

Could I get a pic of the inside?
  • 0
Now you're dead.

#7 PointBlank

PointBlank

    Member

  • Members
  • 528 posts
  • Location:Chicago suburbia

Posted 12 May 2009 - 12:41 PM

A pic would be nice, I am having a hard time following.
  • 0
You can agree with me.... or you can be wrong.

My Latest Mods
The Cyclops
Pointblank Titan

#8 numa-t49

numa-t49

    Member

  • Members
  • 119 posts
  • Location:Jackson NJ
  • State:New Jersey
  • Country:United States

Posted 12 May 2009 - 02:04 PM

Posted Image

The hole still attached is cracked and the other one fell off.
  • 0

#9 BlackFox

BlackFox

    Member

  • Members
  • 286 posts
  • Location:Gorst, Washington

Posted 12 May 2009 - 02:08 PM

Did you replace the spring? The entire force of the spring is being held by those two screw wells. If you didn't, you either got faulty plastic or you're being too rough with your longshot.

That happens to me a lot so I use hot glue to fill the inside it hasn't happened to me again yet.

Hot glue has no structural integrity. I haven't had this problem, but the best advice I can give is to replace the back piece.

If you can't get a new one, you'll have to either scrap it or cover the end with a cut down PVC endcap. It'd be a ton of work though.
  • 0
"Until we meet in the place where there is no darkness"
-George Orwell, 1984
-----------

Think that piece is beyond repair? Think again!


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users