Jump to content


Photo

Mav Drop Clip Problem

AAAAAAAAARRRRRRGGGGHHHHH!!!!!!!!!

2 replies to this topic

#1 skrue luse

skrue luse

    Member

  • Members
  • 17 posts
  • Location:cleburne, IL

Posted 05 March 2009 - 10:21 PM

Unfortunatly, my digicam is kaput, so please bear with me.

Yesterday, I did my first drop clip. I tried it out on an old mav that crapped out a while back. Everything went fine. :D

Today, I did the exact same mod on my lab rat Mav. For some reason, the cylinders won't engage the hex head. :unsure:

I popped them into the husk from yesterday and they both work fine. I would put them in the old one, but it's just a shell with the hex head and cylinder release. <_<

Anyone have any ideas about what's wrong? Thanks!
  • 0

#2 xbox180

xbox180

    Member

  • Members
  • 231 posts
  • Location:NOVA, in Greece for 2 years

Posted 06 March 2009 - 01:59 AM

Maybe, if you increase the strenth of the spring in the cylinder then it will be able to rotate even better.
  • 0
"Congrats on Buy a Peice of Plastic thats most likely older than you, for half- a grand, your awesome man." Nerf Monkey

My Webpage
MY Youtube

#3 skrue luse

skrue luse

    Member

  • Members
  • 17 posts
  • Location:cleburne, IL

Posted 06 March 2009 - 02:19 AM

Maybe, if you increase the strenth of the spring in the cylinder then it will be able to rotate even better.


Tried that. Also tried a spacer in the front. I'm starting to think it's not the cylinders.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users