Jump to content


Whisker's Content

There have been 2 items by Whisker (Search limited from 15-July 93)


By content type

See this member's

Sort by                Order  

#362261 Stampede Won't Fire Without Assistance

Posted by Whisker on 15 January 2018 - 03:34 PM in General Nerf

Your problem could be voltage. My friend's stampede had a similar problem where the plunger tube just wouldn't go far forward enough.

He put a 3s LiPo battery in it, and right away it started to work again. This blaster can handle 12v, but I would recommend doing more research, because another opinion is always helpful. Good luck with that!




#362244 Stampede Won't Fire Without Assistance

Posted by Whisker on 15 January 2018 - 12:21 AM in General Nerf

I am posting this topic because of a very strange issue my Stampede is having.
I opened it up because it wasn't firing. Not because the plunger tube wont move, but because darts simply won't come out of the barrel.
The weird thing is, if I manually assist the plunger tube forwards, it will fire.
I have not replaced any parts or modified this blaster at all, expect of course for taking it apart and hooking it up to a LiPo battery.
I am completely stumped, because this is odd behavior for a blaster.
I apologize in advance for angling the camera too high for some of the video (I had my camera head mounted).
I also apologize for saying 12 dart mag. I meant 6 dart mag.
This is my first post, excuse the nonprofessional filming job. I also don't know how to use tags.
I have no idea what's wrong, if you have any sort of question or comment, please leave it. I love my Stampede.
Thanks guys!
Whisker
 
Video Link: